Read about our upcoming Code of Conduct on this issue

Commit a30b4d71 authored by Pierre Augier's avatar Pierre Augier
Browse files

Avoid dependency on black for now

parent 374135a70e8e
__version__ = "0.0.3"
__version__ = "0.0.4"
try:
from pyfiglet import figlet_format
......
......@@ -8,8 +8,10 @@ from token import tok_name
from io import BytesIO
from pathlib import Path
import black
try:
import black
except ImportError:
black = False
from .log import logger, set_log_level
......@@ -233,7 +235,8 @@ imports: {imports}\n"""
code_pythran += "# pythran export arguments_blocks\n"
code_pythran += "arguments_blocks = " + str(arguments_blocks)
code_pythran = black.format_str(code_pythran, line_length=82)
if black:
code_pythran = black.format_str(code_pythran, line_length=82)
return code_pythran
......
......@@ -9,7 +9,7 @@ classifiers =
Programming Language :: Python :: 3.6
[options]
install_requires = black
# install_requires = black # avoid this dependency for now (see https://github.com/ambv/black/issues/552)
[flake8]
ignore = E501,E225,E226,E303,E201,E202,E203,W503
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment