Read about our upcoming Code of Conduct on this issue

Dropping Python 3.7 compatibility

(including a change that wouldn't work on 3.7)

We recently upgraded the CI images to Debian 11 (Python 3.9).
Binary packages for Heptapod (Docker images notably) have been
shipping Python 3.8 for a very long time, and were upgraded
to 3.9 with Heptapod 0.26
4 jobs for !90 with topic/default/py-3.8 in 1 minute and 57 seconds (queued for 3 seconds)
latest detached
Status Name Job ID Coverage
  Main
passed tests-current #265736

00:01:34

100.0%
 
  Compat
passed check-sdist #265737

00:00:16

passed tests-hg-default #265739

00:00:22

100.0%
passed tests-hg-stable #265738

00:00:21

100.0%