This instance will be upgraded to Heptapod 0.26.0rc1 on 2021-10-26 at 14:00 UTC+2 (a few minutes of down time)

Commit 6682976f authored by Pierre-Yves David's avatar Pierre-Yves David
Browse files

README: more change to have a pretty rendering on pypi

We moves section around and fixes some markup.
parent 667cf3c020da
......@@ -12,18 +12,28 @@ progress.** Please subscribe to the `evolve-testers mailing list <https://www.m
This extensions:
* enables the "changeset obsolescence" feature of Mercurial core
* enables the "changeset obsolescence" feature of Mercurial core
* provides a set of commands to mutate your history,
* provides a set of commands to mutate your history,
* issues several warning messages when troubles from some mutable appears in
your repository,
* issues several warning messages when troubles from some mutable appears in
your repository,
* provides a ``hg evolve`` command to deal with such "troubles".
issues.
* provides a ``hg evolve`` command to deal with such "troubles". issues.
Install
-------
Documentation
-------------
We recommend reading the documentation first. An online version is
available here:
https://www.mercurial-scm.org/doc/evolution/
How to Install
==============
Using Pip
---------
You can install the latest evolution version usin pip::
......@@ -35,13 +45,8 @@ Then just enable it in you hgrc::
[extensions]
evolve =
We recommend reading the documentation first. An online version is
available here:
https://www.mercurial-scm.org/doc/evolution/
Local Install
-------------
From Source
-----------
To install a local version from source::
......@@ -65,8 +70,8 @@ experimental concept to provide lightweight feature branches for the mutable
parts of the history. The experiments is still at an early stage and have
significant usability and performance issues.
enable topic
------------
Enable
------
The topic extensions is included in the evolve package. See the install instruction for evolve.
......@@ -76,24 +81,24 @@ Then enable it in you configuration::
[extensions]
topics =
help
----
Documentation
-------------
* See 'hg help -e topic' for a generic help.
* See 'hg help topics' and 'hg help stack' for help on specific commands.
* See the 'tests/test-topic-tutorial.t' file for a quick tutorial.
* See 'hg help -e topic' for a generic help.
* See 'hg help topics' and 'hg help stack' for help on specific commands.
* See the 'tests/test-topic-tutorial.t' file for a quick tutorial.
Contribute
==========
How to Contribute
=================
Bugs are to be reported on the mercurial's bug tracker (component: evolution):
https://bz.mercurial-scm.org/buglist.cgi?component=evolution&query_format=advanced&resolution=---
Please use the patchbomb extension to send email to mercurial devel. Please
make sure to use the evolve-ext flag when doing so. You can use a command like
this:
this::
hg email --to mercurial-devel@mercurial-scm.org --flag evolve-ext --rev '<your patches>'
$ hg email --to mercurial-devel@mercurial-scm.org --flag evolve-ext --rev '<your patches>'
See also
https://mercurial-scm.org/wiki/ContributingChanges#Patch_descriptions
......@@ -101,10 +106,10 @@ for guidelines on the patch description.
Please don't forget to update and run the tests when you fix a bug or
add a feature. To run the tests, you need a working copy of Mercurial,
say in $HGSRC:
say in $HGSRC::
cd tests
python $HGSRC/tests/run-tests.py
$ cd tests
$ python $HGSRC/tests/run-tests.py
(evolve's stable and default branches correspond to Mercurial's stable
and default branches. So to test evolve from default, you need
......@@ -114,46 +119,52 @@ Mercurial on default.)
Changelog
=========
6.0.0 --
6.0.0 -- In progress
--------------------
- drop compatibility for Mercurial < 3.8,
- removed old (unpackaged) pushexperiment extension,
- move all extensions in the official 'hgext3rd' namespace package,
- add the "topic" experimental extensions.
- officially ship 'evolve.serveronly' extensions. That extensions contains
only the part related to exchange and is intended to be used by server.
- drop compatibility for Mercurial < 3.8,
- removed old (unpackaged) pushexperiment extension,
- move all extensions in the official 'hgext3rd' namespace package,
- add the "topic" experimental extensions.
- officially ship 'evolve.serveronly' extensions. That extensions contains
only the part related to exchange and is intended to be used by server.
Using the extension will enable evolution, use 'experimental.evolution=!'
to disable obsmarkers echange. The old '__temporary__.advertiseobsolete'
option is no longer supported.
Using the extension will enable evolution, use 'experimental.evolution=!'
to disable obsmarkers echange. The old '__temporary__.advertiseobsolete'
option is no longer supported.
5.6.1 -- 2017-02-28
-------------------
- fix a crash that sometime happened when evolving merges.
- fix a crash that sometime happened when evolving merges.
5.6.0 -- 2017-02-01
-------------------
- compatibility with Mercurial 4.1.
- improvement of prune error message.
- fold: require --from flag for folding revisions to working copy
- fix crash when trying to fold an empty revision set (issue5453)
- uncommit: preserve copy information of remaining files (issue5403)
- compatibility with Mercurial 4.1.
- improvement of prune error message.
- fold: require --from flag for folding revisions to working copy
- fix crash when trying to fold an empty revision set (issue5453)
- uncommit: preserve copy information of remaining files (issue5403)
5.5.0 -- 2016-10-30
-------------------
- The {obsolete} template now yield "obsolete" or "".
- compatibility with Mercurial 4.0
- Fix erroneous manifest computation when solving 'bumped' changeset.
- split: avoid crash on empty commit (issue5191),
- next: improve locking to avoid issue with working copy parent (issue5244)
- prev: improve locking to avoid issue with working copy parent (issue5244)
- evolve: fix abort suggestion to include '.' in 'hg update -C .'
- The {obsolete} template now yield "obsolete" or "".
- compatibility with Mercurial 4.0
- Fix erroneous manifest computation when solving 'bumped' changeset.
- split: avoid crash on empty commit (issue5191),
- next: improve locking to avoid issue with working copy parent (issue5244)
- prev: improve locking to avoid issue with working copy parent (issue5244)
- evolve: fix abort suggestion to include '.' in 'hg update -C .'
5.4.1 -- 2016-08-01
-------------------
- compat with Mercurial 3.9
5.4.0 -- 2016-05-06
-------------------
- Some collaboration with the topic experimental extensions,
- hg evolve --all with consider all troubles in your current topic,
......@@ -169,6 +180,7 @@ Changelog
- add a 'metaedit' command to rewrite changeset meta data.
5.3.0 -- 2016-02-11
-------------------
- split: add a new command to split changesets,
- tests: drop our copy of 'run-tests.py' use core one instead,
......@@ -184,6 +196,7 @@ Changelog
- updated help for the `evolve` command
5.2.1 -- 2015-11-02
-------------------
- add compatibility with Mercurial 3.6
- prune: fixed possible issue with lock and bookmark
......@@ -192,6 +205,7 @@ Changelog
- take advantage of dirstate/transaction collaboration
5.2.0 -- 2015-06-25
-------------------
- evolve: gain a --rev option to control what revisions to evolve (issue4391)
- evolve: revision are processed in the order they stack on destination
......@@ -211,6 +225,7 @@ Changelog
- next: add a --evolve flag to evolve aspiring children when on a head
5.1.5 -- 2015-06-23
-------------------
- minor documentation cleanup
- support -i option for `hg amend` if commit supports it (3.4)
......@@ -225,6 +240,7 @@ Changelog
parent.
5.1.4 -- 2015-04-23
-------------------
- significant documentation update
- fix issue4616: pulling with bundle2 would crash if common marker when
......@@ -232,6 +248,7 @@ Changelog
- fix the debugobsrelsethashtree command
5.1.3 -- 2015-04-20
-------------------
- discovery: fix misbehaving discovery across python version
- pull: properly install the bundle2 par generator
......@@ -240,26 +257,31 @@ Changelog
- graft: avoid potential deadlock (acquires wlock before lock)
5.1.2 -- 2015-04-01
-------------------
- evolve: prevent a crash in httpclient_pushobsmarkers() when pushing
5.1.1 -- 2015-03-05
-------------------
- debugobsconvert: fix invalid markers during conversion
- discovery: cache some of the obs hash computation to improve performance (issue4518)
- revset: fix some crash with (issue4515)
5.1 -- 2015-01-30
-------------------
- evolve: explicitly disable bookmark on evolve (issue4432)
- evolve: don't abort Mercurial on version mismatch
- compatibility with mercurial 3.3
5.0.2 -- 2014-12-14
-------------------
- evolve: remove dependency to the rebase extension
5.0.1 -- 2014-11-25
-------------------
- amend: fix --logfile argument
- evolve: preserve branch change when evolving
......@@ -270,9 +292,8 @@ Changelog
- evolve: make next/prev only move bookmarks optionally
- evolve: tell user which "base of divergent changeset" is not found
5.0.0 -- 2014-10-22
-------------------
- drop compat with Mercurial pre 3.2
- uncommit: add a --rev argument
......@@ -288,6 +309,7 @@ Changelog
4.1.0 -- 2014-08-08
-------------------
- amend: add -D/--current-date option
- amend: add -U/--current-user option
......@@ -301,10 +323,12 @@ Changelog
`experimental.verbose-obsolescence-exchange` variable (default to False).
4.0.1 -- 2014-08-08
-------------------
- createmarkers() accept an iterable (for compat with other extension)
4.0.0 -- 2014-06-03
-------------------
- require Mercurial version 3.0.1 or above
- some compatibility fixes with future 3.1.0
......@@ -327,6 +351,7 @@ Changelog
- add a hook related to the new commands
3.3.2 -- 2014-05-14
-------------------
- fix a bug where evolve were creating changeset with 2 parents on windows
(fix issues #16, #35 and #42)
......@@ -336,6 +361,7 @@ Changelog
- fold: add squash as an alias
3.3.1 -- 2014-04-23
-------------------
- various language fix
- active bookmark now move when using prev/next (#37)
......@@ -344,6 +370,7 @@ Changelog
- fold: enable --date and --user options
3.3.0 -- 2014-03-04
-------------------
- raise Mercurial's minimal requirement to 2.7
- drop `latercomer` and `conflicting` compatibility. Those old alias are
......@@ -356,6 +383,7 @@ Changelog
- report troubles creation from `hg import`
3.2.0 -- 2013-11-15
-------------------
- conform to the Mercurial custom of lowercase messages
- added a small extension to experiment with obsolescence marker push
......@@ -369,6 +397,7 @@ Changelog
- Tested with 2.6, 2.7 and 2.8
3.1.0 -- 2013-02-11
-------------------
- amend: drop deprecated --change option for amend
- alias: add a grab alias to be used instead of graft -O
......@@ -380,23 +409,28 @@ Changelog
- prune: add -u and -d option to control metadata
3.0.0 -- 2013-02-02
-------------------
- compatibility with 2.5
2.2.0 --
-------------------
- make evolve smarter at picking next troubled to solved without --any
2.1.0 -- 2012-12-03
-------------------
- qsync fixes
- have qfold ask for commit message
2.0.0 -- 2012-10-26
-------------------
- compat with mercurial 2.4
1.1.0 -- 2012-10-26
-------------------
- fix troubles creation reporting from rebase
- rename latecomer to bumped
......@@ -404,6 +438,7 @@ Changelog
- smarter divergent handling
1.0.2 -- 2012-09-19
-------------------
- fix hg fold bug
- fix hg pull --rebase
......@@ -411,11 +446,13 @@ Changelog
- adapt to core movement (caches and --amend)
1.0.1 -- 2012-08-31
-------------------
- documentation improvement
- fix a performance bug with hgweb
1.0 -- 2012-08-29
-------------------
- Align with Mercurial version 2.3 (drop 2.2 support).
- stabilize handle killed parent
......@@ -436,6 +473,7 @@ Changelog
0.7 -- 2012-08-06
-------------------
- hook: work around insanely huge value in obsolete pushkey call
- pushkey: properly handle abort during obsolete markers push
......@@ -447,12 +485,14 @@ Changelog
- evolve: graft --continue is optional, test
0.6 -- 2012-07-31
-------------------
- obsolete: change warning output to match mercurial core on
- qsync: ignore nonexistent nodes
- make compat server both compatible with "dump" and "dump%i" version
0.5 -- 2012-07-16
-------------------
- obsolete: Detect conflicting changeset!
- obsolete: adapt to core: marker are written in transaction now
......@@ -462,12 +502,14 @@ Changelog
0.4.1 -- 2012-07-10
-------------------
- [convert] properly exclude null successors from conversion
- Ignore buggy marker in newerversion
0.4.0 -- 2012-07-06
-------------------
- obsolete: public changeset are no longer latecomer.
- obsolete: move to official binary format
......@@ -475,6 +517,7 @@ Changelog
- obsolete: we are not compatible with 2.1 any more
0.3.0 -- 2012-06-27
-------------------
- obsolete: Add "latecomer" error detection (stabilize does not handle resolution yet)
- evolve: Introduce a new `uncommit` command to remove change from a changeset
......@@ -488,6 +531,7 @@ Changelog
- template: add an {obsolete} keyword
0.2.0 -- 2012-06-20
-------------------
- stabilize: improve choice of the next changeset to stabilize
- stabilize: improve resolution of several corner case
......@@ -495,5 +539,3 @@ Changelog
- rebase: handle --collapse
- evolve: add `obsolete` alias to `kill`
- evolve: add `evolve` alias to `stabilize`
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment