Commit 69c387b6 authored by Anton Shestakov's avatar Anton Shestakov
Browse files

tests: actually use the correct python version for flake8/pyflakes

parent 2895b026ba88
......@@ -17,4 +17,4 @@ run flake8 if it exists; if it doesn't, then just skip
$ hg files -0 'set:(**.py or grep("^#!.*python")) - removed()' \
> -X hgext3rd/evolve/thirdparty \
> 2>/dev/null \
> | xargs -0 flake8
> | xargs -0 "$PYTHON" -m flake8
......@@ -10,4 +10,4 @@ run pyflakes on all tracked files ending in .py or without a file ending
$ hg files -0 'set:(**.py or grep("^#!.*python")) - removed()' \
> -X hgext3rd/evolve/thirdparty \
> 2>/dev/null \
> | xargs -0 pyflakes 2>/dev/null
> | xargs -0 "$PYTHON" -m pyflakes 2>/dev/null
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment