Commit be8c737a authored by Pierre-Yves David's avatar Pierre-Yves David 🐙
Browse files

branching: merge stable into default

Pipeline #12656 failed with stage
in 4 minutes and 34 seconds
......@@ -89,3 +89,4 @@ ef41094c34e162eb32ef24bf66d9776d1112751a 9.2.2
27d57ca8686590867e62e3d42c96bad84a5f56ef 10.0.0
fb543438704b73b22023a493c9ef76fc8746b796 10.0.1
1cce884c944830a7b331a17fd18614b93cbac987 10.0.2
782cbadb123fe4991e91a03d367e02d0b5ae969c 10.1.0
Changelog
=========
10.1.0 - in progress
10.1.0 -- 2020-10-31
--------------------
* compatibility with Mercurial 5.6
* numerous minor changes to packaging, Makefile, README moved to README.rst
* metaedit: update bookmark location when applicable
* evolve: various improvements to content-divergence resolution
* evolve: fix various issues with --continue when solving content-divergence
* rewind: add a --dry-run flag
* rewind: properly record rewind of splits as folds
* evolve: specify the source of config override for `server.bundle1=no`
* evolve: avoid leaving mergestate after instability resolution
* evolve: while resolving conflicts, the evolved node will no longer be a
dirstate parent (won't show up in `hg parents` and not as `@` in `hg log -G`,
but it will show up as `%` with hg >= 5.4)
* metaedit: update bookmark location when applicable
* rewind: add a --dry-run flag
* rewind: properly record rewind of splits as folds
topic (0.20.0)
* stack: support foo#stack relation revset (hg-5.4+ only)
* merge: add a experimental.topic.linear-merge option to allow oedipus merges
in some cases
10.0.3 - in progress
--------------------
* evolve: specific the source of config override for `server.bundle1=no`
* metaedit: update bookmark location when applicable
10.0.2 -- 2020-09-08
--------------------
......
mercurial-evolve (10.1.0-1) unstable; urgency=medium
* new upstream release
-- Pierre-Yves David <pierre-yves.david@ens-lyon.org> Sat, 31 Oct 2020 18:42:05 +0100
mercurial-evolve (10.0.2-1) unstable; urgency=medium
* new upstream release
......
......@@ -5,7 +5,7 @@
# This software may be used and distributed according to the terms of the
# GNU General Public License version 2 or any later version.
__version__ = b'10.1.0.dev'
testedwith = b'4.6.2 4.7 4.8 4.9 5.0 5.1 5.2 5.3 5.4 5.5'
__version__ = b'10.2.0.dev'
testedwith = b'4.6.2 4.7 4.8 4.9 5.0 5.1 5.2 5.3 5.4 5.5 5.6'
minimumhgversion = b'4.6'
buglink = b'https://bz.mercurial-scm.org/'
......@@ -232,9 +232,9 @@ colortable = {b'topic.active': b'green',
b'topic.active': b'green',
}
__version__ = b'0.20.0.dev'
__version__ = b'0.21.0.dev'
testedwith = b'4.6.2 4.7 4.8 4.9 5.0 5.1 5.2 5.3 5.4 5.5'
testedwith = b'4.6.2 4.7 4.8 4.9 5.0 5.1 5.2 5.3 5.4 5.5 5.6'
minimumhgversion = b'4.6'
buglink = b'https://bz.mercurial-scm.org/'
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment