Commit c2cf2a09 authored by Anton Shestakov's avatar Anton Shestakov
Browse files

evolve: drop the deprecated --unstable, --divergent and --bumped flags

parent 656edde3a8ce
Pipeline #25569 failed with stage
in 15 minutes and 39 seconds
...@@ -7,6 +7,9 @@ Changelog ...@@ -7,6 +7,9 @@ Changelog
* next: add an --abort flag * next: add an --abort flag
* evolve: use a more stable criteria for picking p1 when solving * evolve: use a more stable criteria for picking p1 when solving
content-divergence (most recent evolution will be used). content-divergence (most recent evolution will be used).
* evolve: drop the deprecated --unstable, --divergent and --bumped flags,
they were replaced by --orphan, --content-divergent and --phase-divergent
respectively a long time ago
10.3.2 -- 2021-05-28 10.3.2 -- 2021-05-28
-------------------- --------------------
......
...@@ -1475,28 +1475,6 @@ def _checkevolveopts(repo, opts): ...@@ -1475,28 +1475,6 @@ def _checkevolveopts(repo, opts):
if opts['all']: if opts['all']:
raise error.Abort(_(b'cannot specify both "--rev" and "--all"')) raise error.Abort(_(b'cannot specify both "--rev" and "--all"'))
# Backward compatibility
if opts['unstable']:
msg = (b"'evolve --unstable' is deprecated, "
b"use 'evolve --orphan'")
repo.ui.deprecwarn(msg, b'4.4')
opts['orphan'] = opts['unstable']
if opts['divergent']:
msg = (b"'evolve --divergent' is deprecated, "
b"use 'evolve --content-divergent'")
repo.ui.deprecwarn(msg, b'4.4')
opts['content_divergent'] = opts['divergent']
if opts['bumped']:
msg = (b"'evolve --bumped' is deprecated, "
b"use 'evolve --phase-divergent'")
repo.ui.deprecwarn(msg, b'4.4')
opts['phase_divergent'] = opts['bumped']
return opts return opts
def _cleanup(ui, repo, startnode, shouldupdate, headnode): def _cleanup(ui, repo, startnode, shouldupdate, headnode):
...@@ -1557,11 +1535,8 @@ def divergentsets(repo, ctx): ...@@ -1557,11 +1535,8 @@ def divergentsets(repo, ctx):
_(b'also consider troubled changesets unrelated to current working ' _(b'also consider troubled changesets unrelated to current working '
b'directory')), b'directory')),
(b'r', b'rev', [], _(b'solves troubles of these revisions'), _(b'REV')), (b'r', b'rev', [], _(b'solves troubles of these revisions'), _(b'REV')),
(b'', b'bumped', False, _(b'solves only bumped changesets (DEPRECATED)')),
(b'', b'phase-divergent', False, _(b'solves only phase-divergent changesets')), (b'', b'phase-divergent', False, _(b'solves only phase-divergent changesets')),
(b'', b'divergent', False, _(b'solves only divergent changesets (DEPRECATED)')),
(b'', b'content-divergent', False, _(b'solves only content-divergent changesets')), (b'', b'content-divergent', False, _(b'solves only content-divergent changesets')),
(b'', b'unstable', False, _(b'solves only unstable changesets (DEPRECATED)')),
(b'', b'orphan', False, _(b'solves only orphan changesets (default)')), (b'', b'orphan', False, _(b'solves only orphan changesets (default)')),
(b'a', b'all', None, _(b'evolve all troubled changesets related to the current' (b'a', b'all', None, _(b'evolve all troubled changesets related to the current'
b' working directory and its descendants (default)')), b' working directory and its descendants (default)')),
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment