Read about our upcoming Code of Conduct on this issue

Commit 0f96a90c authored by Dan Villiom Podlaski Christiansen's avatar Dan Villiom Podlaski Christiansen
Browse files

ci: use coverage from PyPI on Ubuntu

I'm seeing warnings like this:

    CoverageWarning: Couldn't use data file
    '/builds/mercurial/hg-git/coverage-279600': Looks like a coverage
    4.x data file. Are you mixing versions of coverage?
parent 695beedb3ee7
Pipeline #31357 passed with stages
in 20 minutes and 42 seconds
......@@ -87,8 +87,10 @@ Ubuntu:
DEBIAN_FRONTEND=noninteractive
apt-get -qq install --no-install-recommends
gnupg gnupg-agent git unzip ssh mercurial
python3-pygments python3-coverage python3-dulwich python3-setuptools
python3-pygments python3-pip python3-dulwich python3-setuptools
pyflakes3
# get latest coverage, otherwise it might not be compatible
- pip install coverage
- useradd test
- chown -R test *
- >
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment