packaging: add a requirements list for CentOS 7

This platform needs to be special cased because QScintilla is now linking
against a newer C library than is available by default.

    ImportError: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by PyQt5/Qsci.abi3.so)

That error triggered an application update check, which triggered a flood of
warnings about OpenSSL symbols, and then a qt.network.ssl warning about an
incompatible version of OpenSSL.  This requires rolling back PyQt5 to something
compatible with 1.0.x, which necessitates rolling back QScintilla a bit further.
The Qt blog says 5.12.4 added support for OpenSSL 1.1.1[1], but experimentation
shows that 5.12.3 also has it.  Using 1.0.2 means there is no TLS 1.3 support.

[1] https://www.qt.io/blog/2019/06/17/qt-5-12-4-released-support-openssl-1-1-1

--HG--
branch : stable
8 jobs for branch/stable in 31 minutes and 51 seconds (queued for 2 seconds)
Status Job ID Name Coverage
  Test
passed #120384
pytype-py3-hg-default

00:31:51

passed #120383
pytype-py3-hg-stable

00:30:57

passed #120377
tests-py2-hg-5.5

00:07:11

passed #120379
tests-py2-hg-default

00:08:26

passed #120378
tests-py2-hg-stable

00:06:15

passed #120380
tests-py3-hg-5.5

00:07:29

passed #120382
tests-py3-hg-default

00:08:14

passed #120381
tests-py3-hg-stable

00:07:01