Skip to content
  • Kyle Lippincott's avatar
    debian: support building a single deb for multiple py3 versions · 36178b5c9aeb
    Kyle Lippincott authored
    Around transitions from one python minor version to another (such as 3.7 to
    3.8), the current packaging can be slightly problematic - it produces a
    `control` file that requires that the version of `python3` that's installed be
    exactly the one that was used on the build machine for the `mercurial` package,
    by containing a line like:
    
        Depends: sensible-utils, libc6 (>= 2.14), python3 (<< 3.8), python3 (>= 3.7~), python3:any (>= 3.5~)
    
    This is because it "knows" we only built for v3.7, which is the current default
    on my system. By building the native components for multiple versions, we can
    make it produce a line like this, which is compatible with 3.7 AND 3.8:
    
        Depends: sensible-utils, libc6 (>= 2.14), python3 (<< 3.9), python3 (>= 3.7~), python3:any (>= 3.5~)
    
    This isn't *normally* required, so I'm not making it the default. For those that
    receive their python3 and mercurial packages from their distro, and/or don't
    have to worry about a situation where the team that manages the python3
    installation isn't the same as the team that manages the mercurial installation,
    this is probably not necessary.
    
    I chose the names `DEB_HG_*` because `DEB_*` is passed through `debuild`
    automatically (otherwise we'd have to explicitly allow the options through,
    which is a nuisance), and the `HG` part is to make it clear that this isn't a
    "standard" debian option that other packages might respect.
    
    Test Plan:
    1. "nothing changed":
        - built a deb without these changes
        - built a deb with these changes but everything at the default
        - used diffoscope to compare, all differences were due to timestamps
    2. "explicit is the same as implicit" (single version)
        - built a deb with everything at the default
        - built a deb with DEB_HG_PYTHON_VERSIONS=3.7
        - used diffoscope to compare, all differences were due to timestamps
    3. "explicit is the same as implicit" (multi version)
        - built a deb with DEB_HG_MULTI_VERSION=1
        - built a deb with DEB_HG_PYTHON_VERSIONS=3.7
        - used diffoscope to compare, all differences were due to timestamps
    4. (single version, 3.7) doesn't work with python3.8
        - `/usr/bin/python3.7 /usr/bin/hg debuginstall` works
        - `/usr/bin/python3.8 /usr/bin/hg debuginstall` crashes
    5. (multi version, 3.7 + 3.8)
        - `/usr/bin/python3.7 /usr/bin/hg debuginstall` works
        - `/usr/bin/python3.8 /usr/bin/hg debuginstall` works
    
    Differential Revision: https://phab.mercurial-scm.org/D8642
    36178b5c9aeb