add implementation_lower to distutils.command.install (issue 3436)

Merged Matti Picus requested to merge branch/distutils-implementation into branch/py3.7

Solves issue #3436 by making sure implementation_lower is instantiated.

Merge request reports